Spectrum TV

Is a certain software version required on my TiVo to use the tuning adapter?

The TiVo must be running software version 9.4 or higher. Only TiVo Series 3, TiVo HD, and TiVo HD XL DVRs are able to support this software version.

If your TiVo needs the software update, you will need to contact TiVo directly to complete the upgrade. Contact TiVo at www.tivo.com or 1-877-367-8486.

Print
Article Number: 3129

Please rate this article

  • Not Helpful
  • Somewhat Helpful
  • Helpful
  • Very Helpful
  • Extremely Helpful
5 stars being extremely helpful

Still need help?

  • We read every feedback carefully but cannot respond to all of them. Please Contact Us if you would like a response.

Related Topics

Helpful Tools & Services